美微网络电视柠檬tv高清完整视频 美微网络电视柠檬tv 美微网络电视柠檬tv高清完整视频 美微网络电视柠檬tv ,bbbb444 第2900免费高清在线观看 bbbb444 第2900免费高清在线观看 ,你好 李焕英 枪版高清完整视频 你好 李焕英 枪版观看 你好 李焕英 枪版高清完整视频 你好 李焕英 枪版观看 美微网络电视柠檬tv高清完整视频 美微网络电视柠檬tv 美微网络电视柠檬tv高清完整视频 美微网络电视柠檬tv ,bbbb444 第2900免费高清在线观看 bbbb444 第2900免费高清在线观看 ,你好 李焕英 枪版高清完整视频 你好 李焕英 枪版观看 你好 李焕英 枪版高清完整视频 你好 李焕英 枪版观看

发布日期:2021年12月09日
温馨提示×

易语言如何实现动态数据加密
九三
81
2021-01-28 19:11:06

易语言如何实现动态数据加密

易语言对动态数据进行加密,具体方法如下:

.版本 2

.支持库 dp1

.子程序 加密_加密or解密, 字节集

.参数 字节集数据, 字节集

.参数 加密or解密, 整数型, , 1加密,2解密

.局部变量 密码文本, 文本型

.局部变量 加密算法, 整数型

.局部变量 word, 文本型

.局部变量 mima1, 文本型

.局部变量 mima2, 文本型

.局部变量 字节集数据中间, 字节集

.如果真 (加密or解密 ≠ 1 或 加密or解密 ≠ 2)

返回 (字节集数据)

.如果真结束

word = “0123456789AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPpQqRrSsTtUuVvWwXxYyZz!#$%'()*+,-./:;<=>?@[\]^_`{|}~&”

.计次循环首 (5, )

mima1 = mima1 + 取文本中间 (word, 取随机数 (1, 93), 1)

mima2 = mima2 + 取文本中间 (word, 取随机数 (1, 93), 1)

.计次循环尾 ()

密码文本 = “www”

加密算法 = 1

.如果真 (加密or解密 = 1)

字节集数据中间 = 到字节集 (mima1) + 字节集数据 + 到字节集 (mima2)

返回 (加密数据 (字节集数据中间, 密码文本, 加密算法))

.如果真结束

.如果真 (加密or解密 = 2)

字节集数据中间 = 解密数据 (字节集数据, 密码文本, 加密算法)

字节集数据中间 = 取字节集中间 (字节集数据中间, 6, 取字节集长度 (字节集数据中间) - 10)

返回 (字节集数据中间)

.如果真结束

0
美微网络电视柠檬tv高清完整视频 美微网络电视柠檬tv 美微网络电视柠檬tv高清完整视频 美微网络电视柠檬tv ,bbbb444 第2900免费高清在线观看 bbbb444 第2900免费高清在线观看 ,你好 李焕英 枪版高清完整视频 你好 李焕英 枪版观看 你好 李焕英 枪版高清完整视频 你好 李焕英 枪版观看
免费拨打  400 100 2938 免费拨打 400 100 2938
24小时售后技术支持 24小时售后技术支持
返回顶部 返回顶部